1

Тема: Вставка функции персчета массива в счетчик

Уважаемые форумчане!
У меня имеется массив, который изменяется при помощи формул, записанных в ячейках, счетчиком. В приведенном примере в ячейке А1 работает счетчик, а в ячейках С6:С16 производится вычисление, то есть умножение ячеек F6:F16 с округлением до 0 на показания счетчика. Как можно записать эту формулу


=ОКРУГЛ($A$1*F6;0)

в макрос счетчика:


Public Sub Counter()

Dim CounterCell As Range, i As Long
     Set CounterCell = ActiveSheet.Range("A1")
                     CounterCell.Value = 0
Application.ScreenUpdating = False

Do While CounterCell.Value < 1000000#
    CounterCell.Value = CounterCell.Value + 0.01
        
Loop

Application.ScreenUpdating = True

End Sub

чтобы персчет призводился при каждом изменении счетчика?

Post's attachments

Пример для вставки функции персчета массива.rar 19.13 kb, 3 downloads since 2018-10-02 

You don't have the permssions to download the attachments of this post.

2

Re: Вставка функции персчета массива в счетчик

1. Не могу открыть приложенный файл *.xlsb в своей старой версии Office 2003.
2. Не могу понять, чего Вы хотите.